We’re in this together! Stay safe with our COVID-19 guide

View
×
Developed in part with a grant from
the National Science Foundation

Michael W.

  • 1 Review
  • 1 Helpful Vote
  • 0 Thank Yous

Experience: Autos & Vehicles

Member since April 2019

  • Review

    1

  • First Reviews

    0

  • Thank Yous

    0

  • Fans

    0

  • Profile Views

    43

Review Distribution

1 Review by Michael

4/12/19
BEWARE of their so-called Service Department. Traveling through Bend on March 27th I had to tow my 2008 Toyota Highlander here because of a sudden loss of oil pressure. Warning lights came on and I immediately pulled over. Less then 2 miles from the dealership, still ended up towing the vehicle to them (thank goodness for AAA). I used the drop box and left the keys there cause no one would talk with us because the Service Department closed 30 mins prior (even though there were people from the department still there).

Called the next morning multiple times to find out they determined it was an oil cooler hose. They told me the "old oil hose" from the factory didn't work well, so now they replace it with a metal pipe assembly. Finally, at 4:07pm (2 hours before they closed) they said they would have to fix it the following morning. Long story short, 12:30pm Fri March 29th (almost 2 days after dropping off my car there) and $500 later, I was able to get my SUV Back. Drove it back to Sunriver area NO problem. Next day drove it up to Mt Bachelor, NO problem. Even drove it back home to Portland on Sunday, NO problem. Never once was there any engine noises or warning lights that came on during our trip home roughly 200 mile trip home.

Wednesday April 3rd comes around (1 week later) and I notice a small amount of oil in my driveway. Not a large amount by any means, but oil never the less. Ran a few errands, stopped by my in laws house to drop something off. No one parks in their driveway, both cars stay in their garage. Once I left, my father in law texted me a picture of oil in their driveway exactly where I was recently parked. I swung by and picked up my son from school that was only a few blocks away. Started to head home and realized there was now an engine knock that just started. NO Check Engine lights, no service notifications, no indication of anything wrong. Once again, pulled immediately over and towed the car to another Toyota dealership near me.

I now have the new dealership saying I need a NEW motor. I find this highly suspicious, I all of a sudden need a NEW motor right after I had work done by Kendall Toyota and it was given the "all clear". This car ONLY has 103K miles on it, VERY under mileage for a 2008 (average of 9364 miles/year). I have almost a 1-inch thick folder of ALL the maintenance that has been done on this car since NEW. It has always driven perfect with no noises or issues what so ever. Be VERY cautious of letting Kendall Toyota of Bend work on your vehicle, it will come out 1000 times worst then when you left it with them. DO NOT TRUST THEM WITH YOUR VEHICLES what so ever.

Michael Has Earned 1 Vote

Michael W.'s review of KendallToyotaOfBend earned a Very Helpful vote

Michael hasn’t received any thanks yous.

Michael doesn’t have any fans yet.

Michael isn’t following anybody yet.

Similar Reviewers on Sitejabber

ericd86
10/11/16

Do not trust Kendall Toyota of Bend. Liars, Yo-Yo financing, Spot delivery, Don't do it. Was told...